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Objective of the Course:

CFD gives insights into flow pattern that are difficult, expensive or impossible to study using
traditional techniques (Experimental) techniques.

Introduction:

From the 1960s onwards the aerospace industry has integrated CFD techniques into the design, R&D
and manufacture of aircraft and jet engines. More recently the methods have been applied to the design
of internal combustion engines, combustion chambers of gas turbines and furnaces. Furthermore,
motor vehicle manufacturers now routinely predict drag forces, under-bonnet air flows and the in-car
environment with CFD. Increasingly CFD is becoming a vital component in the design of industrial
products and processes.

Wind-tunnel testing is typically limited in the Reynolds number it can achieve, usually short of full
scale. Very high temperatures associated with coupled heat transfer fluid flow problems are beyond
the scope of many experimental facilities. This is particularly true of combustion problems where the
changing chemical composition adds another level of complexity.

There are several unique advantages of CFD over experiment-based approaches to fluid systems
design:

(i)substantial reduction of lead times and costs of new designs

(ii) ability to study systems where controlled experiments are difficult or impossible to perform (e.g.
very large systems)

(iii)ability to study systems under hazardous conditions at and beyond their normal performance limits

(e.g. safety studies and accident scenarios) G’,?‘ LL-\/’;/'-
(iv) practically unlimited level of detail of results
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(iv) is increasingly more cost-effective than wind-tunnel testing.
(v) produces a lower energy consumption.

Industry Growth

the investment costs of a CFD capability are not small, but the total expense is not normally as great as
that of a high-quality experimental facility.

o The growth of the market can be attributed to rapid innovations in the aerospace and
aeronautical and automobile industries.

« The global computational fluid dynamics market attained a value of USD 1.8 billion in 2020.
The computational fluid dynamics (CFD) market share is expected to increase by USD 606.76
million from 2022 to 2025, and the market’s growth momentum will accelerate at a CAGR of

12%.

e 37% of the market's growth will originate from Europe, Evolving opportunities with Altair
Engineering Inc., and ANSYS Inc. Market growth will be faster than the growth of the
market in other regions.

Industries
Aero/Aviation/Automotive industries working with CFD:

Defence Research and Development Organisation (DRDO) Labs like, Advanced Systems
Laboratory (ASL), Defence Research & Development Laboratory (DRDL), Advanced Numerical
Research & Analysis Group (ANURAG), Gas Turbine Research Establishment (GTRE), Naval
Science & Technological Laboratory (NSTL), Hindustan Aeronautics Limited(HAL), Aeronautical
Development Agency (ADA), National Aerospace Limited (NAL), Indian Space Research
Organisation (ISRO) etc., BHEL,

MNCs like SIEMENS, GE, Altair Engineering Inc., ANSYS Inc., Autodesk Inc., COMSOL AB,
Convergent Science Inc., and Dassault Systemes SE, ESI Group, Hexagon AB, PTC Inc., and Siemens
AG, Tech Mahindra, Wipro, HCL, GREAVES TECHNOLOGIES LIMITED , Caterpillar Inc, Intel,
Infotech etc.,

Selection criteria:
o Students will be selected based on their CGPA in 2:1 ratio (10 students per course)
o Students has to give interview
o based on performance 10 students will be selected.

Modalities of the conduction of course:
o The course of 30 hours planned to conduct during college timings in Library period.
« Interested Students has to apply for the course.

o Students need to Submit all assignments and Present real time case study during the course as a
project report.

« Certificate will be issued after completion of the course to the students with 80% attendance.

K, (,
Outcome of the course: After completion of course students will be able to (v o
1. Differentiate laminar and turbulent flow problems. ASSOCIATE PROFESSOR &
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2. Analyze fluid flow distribution IC engine components.
3. Evaluate the importance and effect of angle of attack on aerofoil
4. Calculate the mach number, shock angle, pressure coefficient along the wedge and drag
coefficient.
5. Present case studies related to aero and automobile industry
List of learning modules
Module . Topie Duration
No. (Hrs)
Module-1 | Introduction; Governing equations used in CFD, Introduction to ANSYS 5
| Fluent, Study of the numerical solution to a Laminar & Turbulent flows
Module-2 | Study of flow distribution in IC engine components like combustion 5
| chamber, exhaust manifold etc.
Module-3 | Analyze effect of angle of attack on aerofoil NACA 0012 (Compressible 5
..... ) Flow)
Module-4 | Simulation of Supersonic Flow Over a Wedge to 5
calculate the Mach Number, shock angle, pressure coefficient along the
| wedge and drag coefficient.
Module-5 | Case studies based on Aerospace industrial problems. 5
Module-6 | Case studies based on Automobile industrial problems. 5

IC Engine wall Boundary

S S S S S S

" L=1m

Consider a fluid flowing across a flat plate, as illustrated above. The plate length is 1 m. Hight is
0.5 m. The incoming fluid is flowing in the x-direction with a velocity of 1 m/s. The density of the
fluid is 1 kg/m”3 and the viscosity is 1 x 10 ~(-4) kg/(m-s). Obtain the velocity and pressure
distribution when the Reynolds number based on the plate length is 10,000.

Step 1: Pre-Analysis and Start-Up

Pre-Analysis Q:)EJ C L\._)/’
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o Start> All Programs> Ansys 15 > Workbench
The following figure shows the workbench window.
Step 2: Geometry
e Fluid Flow(FLUENT) Project Selection
e Left click (and hold) on Fluid Flow (FLUENT), and drag the icon into the empty space

m

e Advance Geometry Options, change the Analysis  Type
Launch Design

Modeler
e Inthe Project Schematic, double click on Geometry

Creating a Sketch
e XVYPlane. Under Tree Outline,

o seclect XYPlane,> Sketching > Details View.> Sketching Toolboxes.
e select Rectangle. In the Graphics window, create a rough rectangle by clicking once on
the origin and then by clicking once somewhere in the positive XY plane.

Dimensions
o Sketching Toolboxes > select Dimensions tab, use the default dimensioning tools.

e Under the Details View > V1=0.5m and set H2=1m, as shown in the image below.

Surface Body Creation
e (Click )Concept > Surface From Sketches
o SurfaceSKI. Under Details View, sclect Sketchl as Base Objects. Tinally,
click Generate to generate the surface.

Step 3: Mesh

Launch Mesher
e Workbench Project Page, then (Double Click) Mesh.
e click onMesh, then click onUpdateas shown in the image below.
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e Mesh Control > Mapped Face Meshing as can be seen below.

(Click) Apply in the Details of Mapped Face Meshing
e Now, generate the mesh by clicking Update.
Edge Sizing
e (Click) Mesh Control > Sizing
@.., Mesh Control h let

| % Method

® Contact Sizing

o (Click) Edge Selection Filter, B Then hold down the "Control” button and then
click the bottom and top edge of the rectangle. Both sides should highlight green. Next,
hit Apply under the Details of Sizing table as shown below.

e Now, setTypetoNumber of Divisionsas shown in the image below.
Then, set Number of Divisions to 50 as shown below.

etedend Vi Sy’ - Rne *
= Mopn
‘Sraping Method smetny Selettion il

i Esdgas

Ho
Humtes gf Panyiony

o =)
Cursstue=s Hormat dngte | Delet
G wih P A \e MMIL =
B 1 Type !Ic &s 5

Edge Sizing Biasing
Behavior !-latd -

No Bias
e Bias Factor to 70 as shown below. The Bias Factor is defined in this case to be the
ratio of the longest division and the shortest division. That is, the last division will be
seventy  times longer  than  the  length of the  first  division.

(Click) Mesh Control > Sizing > Type to Number of Divisions and seLNnmbe; of

Divisions to 60.> Behavior to Hard and set Bias Type ( PLL /

e setthe Bias Factor to 70> click Update to generate the new miigi
IATE PROFESSOR &
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e (Click) Edge Selection Filter, . Then click on the left side of the rectangle and it
should highlight green. Next, right click the left side of the rectangle and choose Create
Named Selection as shown below.

far_lield
inlet outlet

plate

e Create Named Selection. Enter "inlet" and click OK, as shown below.
Now, create named selections for the remaining three sides and name them

Save, Exit & Update

o Workbench Project Page and click the Update Project button,

Step 4: Se Physi
Launch Fluent
Double click on Setup
e FLUENT Launcher appears change the options to "Double Precision”, and then
click OK
Define Solver Properties
o Models > Energy-Off > Edit...,
o Models > Viscous - Laminar > Edit...,
e By default, the Viscous Model options are set to laminar
Define Material Properties
(Click) Materials > Fluid > Create/Edit...
Density to 1kg/m”3 (constant)
Viscosity to 1e-4 kg/(ms) (constant)
Click Change/Create. Close the window.
Define Boundary Conditions

Inlet Boundary Condition
e (Click) Boundary Conditions > inlet > Edit...

e Boundary Condition Type > velocity-inlet.
o  Velocity Specification Method to Components

- Update Praject

o X-Velocity (m/s) to 1 m/s, as shown below.
e Then, click OK to close the Velocity Inlet menu.

Outlet Boundary Condition
e (Click) Boundary Conditions > outlet > Edit

e  Boundary Condition Type > pressure-outlet.
Plate Boundary Condition
e Boundary Condition Type >to wall

Far-Field Boundary Condition

e  Boundary Condition Type > symmetry,
e symmetry boundary conditions sets the velocities normal to the boundary equal tg zero.
: 2 2\ ( g o
Step 5: Solution N I —
( OV
o Solution Methods > Momentum > Second Order Upwind

Set Convergence Criteria 3539C|ATE PROFESSOR & HE
e (Click) Monitors > Residuals > Edit..., Chz‘i;:;yg‘gt:tar%fthhi‘;zz:;:c :f|T§;?t:n
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Set Initial Guess

o Solution Initialization > Compute from > inlet

e click the Initialize button, m This completes the initialization process.
Iterate Until Convergence

e Run Calculation > Number of Iterations to 1000, as shown in the image below

Step 6. Results

Double click on Results from the Workbench Window to launch CFD-Post.
Velocity Vectors

Fiﬂeedn Seqson m—l'rools Help

BEY% S 9 ¢ Dlomim v an@ o g [ o

outne | veristies || Exresons | w«ln-w % B @
w| Cases -] =
4 9] User Locations and Plots
Y Default rarform
¥ [} Defauit Legend view 1
(¥ 0D weeframe

=

Locations to symmetry 1. Click on Apply to display the velocity vectors.
The velocity vectors will be displayed in the view window.
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Pressure Contour

Insert > Contour. Name it Pressure contour.
Click on Apply to view the contour.
Outlet Velocity Profile

insert > location > line. Name it "Outlet"
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External Flow Problem

R4

j‘.

Consider the steady state case of a fluid flowing past a cylinder, as illustrated above. In order to
simplify the computation, the diameter of the cylinder is set to 1 m, the x component of the
velocity is set to 1 m/s and the density of the fluid is set to 1 kg/m”3. Thus, the dynamic viscosity
must be set to 0.05 kg/m*s in order to obtain the desired Reynolds number. '
Obtain the velocity and pressure distributions when the Reynolds number is chosen to be 20.

1. Pre-Analysis & Start-Up

D=64m

~

Wall"
a=0

“Velocity

inlet’ . —> _ “Pressure
ii=1 € Outlet”

P=0

/
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2. Geometry
o Drag Fluid Flow(FLUENT) into the Project Schematic window.
Analysis Type
e (Right Click) Geometry > Properties Set Analysis Type to 2D
Launch Design Modeler
e (Double Click) Geometry
Create Inner Circle and Dimension
e Create a circle, centered around the origin in the Xy plane. Set the diameter of the circle to

Im.
Inner Circle Surface Body Creation
e Concept > Surfaces From Sketches.
e Base Object to Sketch 1 (located underneath XYPlane in the Tree). Click Generate
Create New Sketch in the XY Plane
e Click on XYPlane in the Tree OQutline and it should highlight blue. Then click on

the New Sketch button, el
Create Outer Circle and Dimension
e Set the diameter of the circle to 64m.
Outer Circle Surface Body Creation

e Concept > Surfaces From Sketches.
Base Objectto Sketch 2 (located wunderncath X¥YPlane in the Tree). Then
set Operation to Add : Frozen

Then, click Generate
Carry Out Boolean Operation: Subtraction
e Create > Boolean,
Operation to Subtract.

e use the face selection filter, ®,
e to apply the outer circle surface body as the Target Body.

e use the face selection filter, IE, to apply the inner circle surface body as the Tool Body.
Lastly, click Generate.

Create a Bisecting Line
e Click on XYPlane

e Then, click the new sketch button, 2

e In the new sketch draw a line on the y axis that goes through both of the concentric circles.
Make sure that it is coincident to the y axis.

e Then trim the line segments that lay inside of the inner circle and the line segments that lay
outside of the outer circle.

Line Body Creation

e Concept > Lines From Sketches.
Set the Base Object to Sketch 3. (located underneath XYPlane in the Tree)i}\) S '”.’
Click Generate

-

ASSOCIATE PROFESSOR &

12

HEAD

Department of Mechanical Engifeering
Chaitanya Bharathi Institute of T y (A)
Gandipe!, Hyderabad-560 075. Telgngana.




12 13

Projection
e Tools > Projection.
Apply the two lines that you created to edge and apply the surface body to target.
o Click Generate.
e Save Project and Close Design Modeler

3. Mesh
Launch Mesher
e (Double Click) Mesh
Mapped Face Meshing
e (Right Click) Mesh > Insert > Mapped Face Meshing
e Click Update.
Circumferential Edge Sizing
e (Right Click) Mesh > Insert > Sizing
e Set Type to Number of Divisions, set Number of Divisionsto 96 and
set Behavior to Hard.
e Click Update to generate the new mesh.
Radial Edge Sizing 1 (Top Half)
o (Right Click) Mesh > Insert > Sizing
e Typeto Number of Divisions, setNumber of Divisions to 96 and
set Behavior to Hard.

Radial Edge Sizing 2 (Bottom Half)

Create Named Selections

cylinderwall

farfieldl farfield2

4. Setup (Physics)

Launch Fluent
e (Double Click) Setup inthe Workbench Project Page.
e Select Double Precision.
Specify Material Properties
e Problem Setup > Materials > Fluid > Create/Edit....
e Densityto 1 kg/m”3 and set Viscosity to 0.05 kg/m*s. Click Change/Create then

_ click Close.
Boundary Conditions
FarField1
e Problem Setup > Boundary Conditions > farfieldl.
velocity-inlet. Click Edit.... (M=
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e Set Velocity Specification Method to Components, set X-Velocity to 1 m/s, and
set Y-Velocity to 0 m/s.
‘FarField2
e Problem Setup > Boundary Conditions > fuarfield2..
Set Type to pressure-outlet.
Cylinder Wall
e Problem Setup > Boundary Conditions > cylinderwall.
Set Type to wall.
Reference Values
e Problem Setup > Reference Values.
Set the Density to 1 kg/m”3. The other default values will work for the purposes of this
simulation.
Save Project
5. Solution
Second Order Upwind Momentum Scheme
o Solution > Solution Methods > Spatial Discretization.
Set Momentum to Second Order Upwind
Convergence Criterion
o Solution > Monitors > Residuals > Edit....
Set the 4 bsolute Criteria for , x-velocity and y-velocity all to le-6. Click ok
o Solution > Monitors > Drag > Edit....
Then check Print to Console and Plot. Next, click cylinderwall, which is located
under Wall Zones. Lastly, click ok
Initial Guess
e Solution > Solution Initialization.
o Compute From to farfieldl.
o click Initialize.
Iterate Until Convergence
e Solution > Run Calculation.

e Number of Iterations to 2000. Then, click Calculate. Save Project

6. Results
Velocity Vectors
e Results > Graphics and Animations > Vectors > Set Up...

14
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Then click Display. The Scale was set to 2 in the plot below. e 11) Jl.»__'_‘_' o =
w \_f e
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Stream Lines
e Results > Graphics and Animations > Contours > Set Up..
Set Contours of to Velocity.. and set the box below toStream Function.
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Vorticity
e Results > Graphics and Animations > Contours > Set Up...
Set Contours of to Velocity..
e set the box below to Vorticity Magnitude.
e Then click Display. The plot below was created by by setting levelsto 60,
deselecting Auto Range, setting Min (1/s)to 0.25 and settingMax (I/s)to 9.

Airfoil
Problem Specification
In this tutorial, we will show you how to simulate a NACA 0012 Airfoil at a 6 degree angle of
attack placed in a wind tunnel. Using FLUENT, we will create a simulation of this experiment.
Afierwards, we will compare values from the simulation and data collected from experiment.

-

Pre-Analysis & Start-Up

-

‘Boundary Conditions
Intet O\ o]
X- Velocity = 9945 mis C =
Y-Velocity = 1045 m/s —
Gauge Pressure =0 Outlet
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1. Geometry
Download the Airfoil Coordinates
Launch Design Modeler
Airfoil
e Concept > 3D Curve. In the Details View window,
e click Coordinates File and select the ellipsis =i to browse to a file.

o click #0enerate o create the curve. Click | "2 o get a better look at the curve.

Concepts > Surfaces from Edges.
e  Click anywhere on the curve you just created, and

o sclect Edges > Apply in the Details View Window. Click - Generate ¢4 create the

surface.
Create C-Mesh Domain

e Click ™ to create a new coordinate system. In the Details View window,
o select Type > From Coordinates. For FDI1, Point X, enter 1.

]
Click ~ Uenerate 1 generate the new coordinate system.

In the Tree Outline Window, select the new coordinate system you created (defaulted

2 to create a new sketch.

to Plane 4), then click
e click the Sketching tab to bring up the sketching window.
e C(Click # Arcby Center
e The first click selects the center of the arc, and the next two clicks determine the end
points of the arc. We want the center of the arc to be at the tail of the airfoil. Click on the
origin of the sketch, making sure the P symbol is showing
For the end points of the arc, first select a point on the vertical axis above the origin (a C symbol
will show), then select a point on the vertical axis below the origin. You should end up with the

following:

;‘%? : - " : - o
g:i rf_zz-. '/p‘l' LIJ- o -
R (EMV=—" "
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To create the right side of the C-Mesh donain,
o click (S Rectangle by 3 Points
e Click the following points to create the rectangle in this order - where the arc meets the
positive vertical axis, where the arc meets the negative vertical axis, then anywhere in the
right half plane. The fina! result should look like this:above fig.

Now, we need to get rid of necessary lines created by the rectangle.

16
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e Select Modify in the Sketching Toolboxes window,

e thenselect - Trim

e Click the lines of the rectangle the are collinear with the positive and negative vertical
axises. Now,

e sclect the Dimensions toolbox to dimension the C-Mesh domain.

e Click (<" Radius , followed by the arc to dimension the arc. Assign the arc a value
of 12.5. Next,

e select Honzental

e Click the vertical axis and the vertical portion of the rectangle in the right half plane. Also
assign the horizontal dimension a value of 12.5.

e Concept > Surface From Sketches.

e Click anywehere on the sketch, and select Base Objects > Apply in the Details
View Window. Also,

e sclectOperation > Add Frozen.

e click ,)’ Gr:nc—rate.

The final step of creating the C-Mesh is creating a surface between the boundary and the

airfoil.
e Create > Boolean.
e Operation > Subtract.
o Target Bodies > Not selected,
e select the large C-Mesh domain surface, then click Apply.
e Repeat the same process to select the airfoil as the Tool Body. When you have

selected the bodies, click ~ Generate

Create Quadrants
e break up the new surface into 4 quadrants;

o select Plane 4 in the Tree Outline Window, and click it \

e Open the sketching menu, and select “.line  Draw a line on the vertical axis that
intersects the entire C mesh. Trim away the lines that are beyond the C-Mesh, and you
should be left with this:

e Concepts > Lines from Sketchs. > click Base Objects > Apply, followed

by E Generate Now that you have created a vertical line, create a new sketch and repeat
the process for a horizontal line that is collinear to horizontal axis and bisects the
geometry.

o Tools > Projection. Select Edges press Ctrl and select on the vertical line we drew
(you'll have to select both parts of it), then press Apply. Next, select Target and select the
C-Mesh surface, then click Apply.

e Once you click % Generate you'll notice that the geometry is now composed of two
surfaces split by the line .Repeat this process to create 2 more projections: one projection
the line left of the origin onto the left surface, and one projecting the right line on the right
surface. When you're finished, the geometry should be split into 4 parts. (_L/’?,*/i!, o
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2. Mesh

‘Mapped Face Meshing
e Mesh Control > Mapped Face Meshing. Making sure the face selection filter is

selected ,

Geometry > Apply. Next, select

Edge Sizing

Mesh Control > Sizing. Next, click the edge selection filter Y .
Select the following 4 edges buy holding Ctrl and using the left mouse button:

Geometry > Apply. Next, select Type > Number of Divisions. Change the Number
of Divisions 10 50.

Select Behavior > Hard. We also want the mesh to have a bias, so select the first bias
type: Bais > ----- — - -, and give the edge sizing a Bius Factor of 150. The Edge sizing
should now look like this:

Create a new edge sizing with the same parameters, but choose the 4 remaining straight
edges (see figure below). The number of divisions will still be 50, but now will be
selecting a different biasing type by selecting the second Bias option: Bias > - - — -----.
Again, set the Bias Factor to 150

third edge sizing, and sclect the rounded edges as the geometry> Type > Number of
Divisions, > Number of Divisions to 100.>Behavior > Hard. This time, we will not
bias the edges.

Mesh > Generate to generate the mesh. It should look like this.

Named Selections

Kx L AT
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Y-Velocity = 1045 m/s
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Gauge Pressure =0

Airfoil = Wall

3. Setup
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Launch the Solver
Select the Solver
Click OK to launch Fluent.
o Problem Setup > General. Under Solver, select Density-Based.

Models and Materials
o Problem Setup > Models > Viscous-Laminar. Then press Edit..

Inviscid and pressOK.

click Problem Setup > Materials > (double click) Air.

Under Properties, ensure that density is set to Constant and enter 1 kg/m"3 as the
density. Click Clrange/Create to set the density.

Boundary Conditions
Inlet
o Problem Setup > Boundary Conditions.

o Velocity Specification Method > Components.

e Specify X-Velocity as 0.9945 m/s and Y-Velocity as 0.1045 m/s. press OK
Qutlet

o Sclect Outlet

o pressure-outlet: if it didn't, select it. Click Edit,

o Gauge Pressure is defaulted to 0.
Airfoil
In the Boundary Conditions window, look under Zones and

o select airfoil. Select Type > Wall if it hasn't been defaulted.

Reference Values
o Problem Setup > Reference Values.>Compute From = Inlet.

Solution

Methods
o Solution ¥ Solution Methods> Second Order Upwind.

Monitors
o Solution > Monitors. In Monitors. Select Residuals - Print,Plot and press E£dif. In
the Residual Monitors Window, we want to change all of the 4bsolute Criteria to ie-
6.

Initial Guess
o Solution > Solution Initialization.> Compute I'rom > Inlet. >clicking Initialize.

Solve
o Solution o Run Cealceulation.  Change Number of  lterations to 3000,

. >click Calculate.
6.Results

Velocity
o Results > Graphics and Animations. > select Vectorsand click Ser Up....

o Vectors of > Velocity, Color by > Velocity, and set the second box as Velocity

Magnitude. To see the velocity vectors, press Display. KG} [};2-”/‘7' '
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Pressure Contours
o Results > Graphics and Animutions > select Contours.

Click Set Up...
e sclected are Pressure... and Static Pressure > press Display
Streamlines
e Contours Of box to Velocity,
e Stream Function. Change Levels to 100. Also, uncheck the box marked Auto Range,
and set Min(kg/s) to 13.11, and Max(kg/s) to 14.16

Turbulent Flow through a Nozzle

Problem Statement:
Consider a convergent-divergent (CD) nozzle with circular cross section. Let that area vary as a
function of the length of the nozzle. Since the area is circular, axisymmetric flow can be assumed and

only the upper portion will be modeled for simplification purposes.

e In Main Menu—Concept select 3d Curve.
e TIn Details View next to Definition specify From Coordinates File.
e Underneath specify the location of the .txt coordinates file.

e (Click Generate.

e Open an Excel file and following the format outlined and using the equation expressing the
radius of the nozzle (y-axis) as a function of the distance (x-axis)—Eq.3,

e create an Excel worksheet and save it as a .txt file. The final result should look like this:
e Fora step size 0.01 is used for the nozzle’s distance range of -0.5 to 0.5 meters.

It is a 2d problem hence the z-dir. coordinates are kept at 0.

As a result 101 coordinate points are specified and it should be noted that the more points that
are entered, the smoother the curve will be.

So far the wall and centerline surfaces have been created—we have 2 edges.
e Next the inlet and outlet ones will be modeled.
e The left edge will represent the inlet and to create the line we need the -0.5, 0, 0 point on the x-
axis alongside its corresponding point on the curve.
e Same applies for the right edge which is to represent the nozzle’s outlet. In order to do that we
will plot the individual points of the curve and manually select the needed points.
o Select Point and specify the .txt coordinate file; click generate.

o The final step before obtaining the geometry for the nozzle is to create the surface from the

existing edge. ( | af {;.-_—"/.J/
| ASSOCIATE PROFESSOR & HEAD
Mesh: create mesh . Department of Mechanical Enginegring
The four boundary zones must be specified. Chaitanya Bharathi Institute of Technology (A)

Gandipet, Hyderabad-500 075. Telangana.
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e Select the edge cube and after selecting an edge

e right click it and choose Create Named Selection.

e Name the left edge “Inlet”, the right one “Outlet”, the top edge “Wall” and the bottom edge
“Centerline”.

\ oot = — —

Considéhr“t_he following valu_;; férﬁ the SpeCif:l_('ihﬂOW problem:

Veinsats — 100m; D, .. = 1.5m;
L.‘?:?'c-'ar =50m D:g:ym:: = 1.0m
Tm:st =2930K
I",.’ane: =024 Ma
A A P
=it . 15, inlst _ 5 g, outlst _ o 7c
Athrmzr Atkron: Pinht

The velocity is given as 0.24 Ma and the specific value must obey only the rule that the inlet
velocity is subsonic. The velocity can be converted to meters per second and it is important to do the
calculation since that value will be entered in ANSYS Fluent in order to set both the reference values

and to initialize the problem. ’
Ma=%cmdc=m 2)

Where: ¢ is the speed of sound which varies with temperature and fluid type. For
‘example the speed of sound in water is much higher than in air.
The stagnation temperature must be calculated as well as it will be entered in Fluent. Equation

3is to be used which stems from the assumed Quasi 1D approach. Note T is the inlet temperature and
T, is the stagnation temperature which is the temperature at a point of zero fluid velocity.

Equation 2 is used to compute the total gauge pressure at the inlet, P. The equation stems
from the assumed Quasi 1D approach and it is important to calculate the pressure since they are to be
entered in Fluent. The stagnation pressure is the pressure at a point of zero fluid velocity and kinetic

energy has been converted to pressure energy. 10 D
2= 1 ASSOCIATE PR
=l— 2 OFESSOR
By (14.?1,‘\,,:) ) Department of Mechanical E ;ﬂﬁ
1201 /(1.401-1) Chaitanya Bharathi Institute of Teghmology
p 1 Gandipet, Hyderabad-500 075, felangan
5 1401—1 =S
Po \145—x24
However, the pressure of the outlet is | atm or 101,325 Pa since the operating pressure is 0
because only the gauge pressures are of interest—-pyey s ~ Pogsraring — O Recall feutier — g 75.

Pinlet




Poutier 101.325 )
¢ 0.75 0.75

s P = PG =1.041 = i40,639 Pa

Problem Setup—Models:
Under Models
e Double click Energy and put a checkmark thus turning it on.

e Press Ok. It is important to consider the energy equation since we are dealing with
compressible flow and we are interested in temperature effects.
e The energy equation now will be calculated alongside the continuity and momentum ones.

Since the Quasi-One dimensional flow approach is assumed for analysis and validation in this tutorial
the flow is assumed to be inviscid. Under Models, double click Viscous and select Inviscid.

Problem Setup-—Materials:
Underneath Materials, under Fluid double

e Click Air. Under Properties

Next to Density specify Ideal Gas. Since in compressible flow the density is not constant, the value
can be seen to be blank. Air is analyzed as an ideal gas. Press Change/Create
Problem Setup—Boundary Conditions:
e Since the fluid flow is assumed to be air as an ideal gas the pressure must be expressed as an
absolute pressure. '
e Click on Operating Conditions and it can be seen that by default the Operating Pressure (gauge

pressure) is set at 101,325 Pa or 1 atm.

Make it equal to 0 and press OK
Change the Axis zone to type Axis (the problem has already been specified as Axisymmetric in the

Problem Setup—General).
e Verify that the wall zone is of type wall, the inlet zone is of type pressure inlet, the outlet

zone if of type pressure outlet and the interior zone is of type interior.

Double click on the outlet zone and enter 101 325 Pa as the outlet gauge pressure
e In the Thermal tab specify the backflow total temperature as 296.375 K. Refer to the problem

statement for the calculations performed to obtain those values. Press OK.

Problem Setup—Boundary Conditions:
e Double click on the inlet zone.

e Enter 140,639 Pa as the Total Gauge Pressure, P.
e Specify 135,100 Pa as the Initial Gauge Pressure, P; (stagnation pressure).

o Refer to the problem statement for the manner in which the two values were obtained

o Set the total temperature in the thermal tab to equal to 296.375 K (ref. to problem statement
for calculation).

o Problem Setup—Reference Values:

e Set the reference values to be computed from the inlet. Verify the values for temperature and
velocity among others make sense. It can be seen there are small variation for the temperature
(it was chosen as 293K at the inlet) and the velocity (it was computed as 82.362 m/s at the
inlet, ref. to Problem Statement Section). (/'ﬁ. Ir"nll',")—-/_:’._f‘#;’
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Conlours of Velocity Magnitude (m’s}) Dec 09, 2010

MACH NUMBER
e The shock inside the nozzle can be clearly seen (circled region). Vast velocity difference is

exhibited on each end of the shock.

VELOCITY IN NOZZLE

@ =

ASSOCIATE PROFESSOR & HEAD
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Wedge with supersonic stream
Problem Specification A uniform supersonic stream encounters a wedge with a half-angle of 15

degrees as shown in the figure below. The stream is at the following conditions:

150

It

M=3

\L’ VW VVV WV

Mach Number M; = 3
Static Pressure p; = 1 atm

Static Temperature Ty = 300k
Using Ansys Fluent, calculate the Mach Number, static and total pressure behind the oblique
shock that will be formed. Also, calculate the shock angle, pressure coefficient along the wedge
and drag coefficient. Compare the Fluent results with the corresponding analytical results.
In the hand calculations we will be applying the conservation of energy, mass and momentum
equations for a 1D inviscid compressible flow. This differs from the way that Fluent solves the
problem, as Fluent instead uses the 2D inviscid compressible flow equations.

—4+u - Ve+=V.u=10 7‘“{“‘4‘ prpV-ou=L

ot P 0

da Vp

—+u-Vu= .t

ot P
1. Geometry
Create Design Modeler

—— !
— s

2. Mesh -
Mesh Control > Face Meshing
click Geometry > Apply
Body Sizing

Mesh Control > Sizing. Next, select the body selection filter in the menu bar:

THLRREEIS Seaq |
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In the Details window, select Geometry > Apply. Element Size > Default and change the value
to 0.05 m. ;

Mesh > Generate Mesh

3. Setup
Launch the Solver-Select the Solver-Click OK to launch Fluent.Energy-On-invicid,

Problem Setupl > General. Under Solver, select density based

Models and Materials

Density to Ideal Gas, the default values for Cp (1006.43), and the Molecular Weight (28.966)
density. Click Change/Create to set the density.
Boundary Conditions

Select farfield. Use the drop-down menu to change the Type to pressure-far-field. Change the
Gauge Pressure (Pascal) to 101325, and Mach Number to 3.Also, select the Thermal tab, and
ensure that the temperature correctly defaulted to 300 K. When you are finished, press OK.

rﬂﬁrmml’am‘_ i;’h . - e, = 1 s) - m
Zone [ane
Momentuny hhem:sl% Rad»aunn? Sparssé ups © DPM ,‘
Gauge Pressure {pescall W |constant Al
I Mach hember I“:“ ——— & l’_w-—m-_ d—.—|
|| ¥-Companent of Flew Dirscion F{' . - ".L;gnslen_l_ =
| v-Cunporent of Flov: Deecuon ,.3— —1 @
_ (o | [conczt| [t |
.' Er— 1T — =y,

Wedge In the Boundary Conditions window, select wedge. change the Type to wall.
Symmetry In the Boundary Conditions window, select symmetry.

Operating Conditions In the Boundary Conditions window, select the Operating Conditions
button. Change the Gauge Pressure to 0. Then press OK

in materials to Ideal Gas, Fluent calculates the density using the absolute pressure. However, the
pressure we specify is the gauge pressure, not the absolute pressure. Fluent will use the absolute
pressure to compute the density, therefore if we do not set the operating pressure to 0 our density
will be incorrect for the flow field.

Reference Values In the Outline window, select Reference Values. Change the Compute From

b=

ASSOCIATE PROFESSOR & HEAD
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Chaitanya Bharathi Institute of Technology (A)
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parameter to farfield.

Solution

Solution Methods to open the Solution Methods window. Under Spatial Discretization, ensure
that the option under Flow Second Order Upwind is selected. Solution Controls In the Outline
window, select Solution Controls to open the Solution Controls window. Ensure that the Courant
Number is set to 5.0.

Solution Initialization

Compute From parameter to farfield.

if your solution is having convergence issues, try to use Third Order MUSCL under Solution
Methods > Spatial Discretization.

Third Order MUSCL helps to converge the solution, especially if you are seeing many
oscillations between a few values in your residuals.

6.Results
Velocity Vectors -
In the Outline window, under Results select Colors and Animations. In the Colors and
Animations window, under Graphics, select Vectors. Then press Set Up....

In the Vectors window that opens, change the Scale of the arrows to 0.25, and change the Color
by parameter to Velocity... Mach Number.

(B
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Z has successfully completed value added course on Computational Fluid Dynamics for wf
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i
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Computational Fluid Dynamics for Automobile and Aviation
| Course Completion Certificate , B

This 1s to certify that Mr./Ms./Mrs Mukund Balraj Vishwanath with Roll No. 1601-20-736-031,
has successfully completed value added course on Computational Fluid Dynamics for

Automobile and Aviation, organised by DEPT OF MECHANICAL ENGINEERING from
24th July 2023 to 11th Nov 2023.
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Computational Fluid Dynamics for Automobile and Aviation

VAVAVAV AT AVA
g D B

Course Completion Certificate

This is to certify that Mr./Ms./Mrs. Banoth Suresh with Roll No. 1601-20-736-106, has
successfully completed value added course on Computational Fluid Dynamics for Automobile

and Aviation, organised by DEPT OF MECHANICAL ENGINEERING from 24th July 2023
to 11th Nov 2023.
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Computational Fluid Dynamics for Automobile and Aviation

[o¥ . Course Completion Certificate

This is to certify that Mr./Ms./Mrs Sri Chandana with Roll No. 1601-20-736-072, has ““ "
successfully completed value added course on Computational Fluid Dynamics for Automobile g
and Aviation, organised by DEPT OF MECHANICAL ENGINEERING from 24th July 2023
to 11th Nov 2023.
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Course Completion Certificate

This is to certify that Mr./Ms./Mrs. Afieen begum with Roll No. 1601-20-736-061, has .\ Mﬂ
successfully completed value added course on Computational Fluid Dynamics for Automobile
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Course Completion Certificate

_ ' This is to certify that Mr./Ms./Mrs. Allagada Nagavishnu with Roll No. 16012736089, has
A successfully completed value added course on Computational Fluid Dynamics for Automobile
<X and Aviation, organised by DEPT OF MECHANICAL ENGINEERING from 24th July 2023

to 11th Nov 2023.
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This 1s to certify that Mr./Ms./Mrs. Bhavani Sankar Chodavarapu with Roll No. 160120736078, K
has successfully completed value added course on Computational Fluid Dynamics for ._._.“
Automobile and Aviation, organised by DEPT OF MECHANICAL ENGINEERING from t.
24th July 2023 to 11th Nov 2023. AJ
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Course Completion Certificate

This is to certify that Mr./Ms./Mrs. G Jashwanth with Roll No. 1601-20-736-080, has
successfully completed value added course on Computational Fluid Dynamics for Automobile
and Aviation, organised by DEPT OF MECHANICAL ENGINEERING from 24th July 2023

to 11th Nov 2023.
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Computational Fluid Dynamics for Automobile and Aviation W

This is to certify that Mr./Ms./Mrs. Aditya Varupula with Roll No. 1601-20-736-074, has
successfully completed value added course on Computational Fluid Dynamics for Automobile X

and Aviation, organised by DEPT OF MECHANICAL ENGINEERING from 24th July 2023 Mﬁ_
to 11th Nov 2023. x
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This is to certify that Mr./Ms./Mrs. Kummara Praneeth Ram with Roll No. 1601-20-736-091,
has successfully completed value added course on Computational Fluid Dynamics for
Automobile and Aviation, organised by DEPT OF MECHANICAL ENGINEERING from
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Course Completion Certificate

This is to certify that Mr./Ms./Mrs. Rishab Erramilli with Roll No. 1601-20-736-093, has
successfully completed value added course on Computational Fluid Dynamics for Automobile
and Aviation, organised by DEPT OF MECHANICAL ENGINEERING from 24th July 2023
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AVALUE ADDED COURSE
on

Computational Fluid Dynamics for Automobile and Aviation

COMMITTED TO
RESEARCH.,
INNOVATION AND
EDUCATION

Course Completion Certificate

This i1s to certify that Mr./Ms./Mrs. Chepuri Ashwini with Roll No. 1601-20-736-304, has
successfully completed value added course on Computational Fluid Dynamics for Automobile
and Aviation, organised by DEPT OF MECHANICAL ENGINEERING from 24th July 2023

to 11th Nov 2023.
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Course Completion Certificate

This is to certify that Mr./Ms./Mrs. Shashi Kiran Mankala with Roll No. 1601-20-736-103, has
successfully completed value added course on Computational Fluid Dynamics for Automobile
and Aviation, organised by DEPT OF MECHANICAL ENGINEERING from 24th July 2023

to 11th Nov 2023.
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Computational Fluid Dynamics for Automobile and Aviation

Course Completion Certificate

This is to certify that Mr./Ms./Mrs. Rohith Chamanthula with Roll No. 1601-20-736-303, has
successfully completed value added course on Computational Fluid Dynamics for Automobile
and Aviation, organised by DEPT OF MECHANICAL ENGINEERING from 24th July 2023 Mt_
to 11th Nov 2023. ..
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A VALUE ADDED COURSE
on

Computational Fluid Dynamics for Automobile and Aviation

n. CHAITANYA BHARATHI

A COMMITTED TO
RESEARCH,
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Course Completion Certificate

This is to certify that Mr./Ms./Mrs. Marikukala Dhana Nivas with Roll No. 1601-20-736-020,
has successfully completed value added course on Computational Fluid Dynamics for
Automobile and Aviation, organised by DEPT OF MECHANICAL ENGINEERING from

24th July 2023 to 11th Nov 2023.
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A VALUE ADDED COURSE
on

Computational Fluid Dynamics for Autom

COMMITIED TO
RESEARCH,
INNOVATION AND
FODUCATION

years

obile and Aviation

Course Completion Certificate

This is to certify that Mr./Ms./Mrs. T. Sai Samanvith with Roll No. 1601-20-736-100, has
successfully completed value added course on Computational Fluid Dynamics for Automobile
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and Aviation, organised by DEPT OF MECHANICAL ENGINEERING from 24th July 2023
to 11th Nov 2023.
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Dr. Ch. Indira Priyadarshini Dr. P. Prabhakar Reddy
Assistant Professor - Dept. of Mechanical Engineering HOD - Dept of Mechanical Engineering
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Computational Fluid Dynamics for Automobile and Aviation Aw,_hﬁ
p &
Course Completion Certificate _ \,,\._%L

This is to certify that Mr./Ms./Mrs. G Chandrakanth Singh with Roll No. 1601-20-736-017, has f/,ﬂw
successfully completed value added course on Computational Fluid Dynamics for Automobile

and Aviation, organised by DEPT OF MECHANICAL ENGINEERING from 24th July 2023
to 11th Nov 2023.
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AVALUE ADDED COURSE
on

Computational Fluid Dynamics for Automobile and Aviation
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Course Completion Certificate

This 1s to certify that Mr./Ms./Mrs. I. Sowmya with Roll No. 1601-20-736-070, has successfully
completed value added course on Computational Fluid Dynamics for Automobile and

Aviation, organised by DEPT OF MECHANICAL ENGINEERING from 24th July 2023 to
11th Nov 2023.
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AVALUE ADDED COURSE
on

Computational Fluid Dynamics for Automobile and Aviation

Course Completion Certificate

This is to certify that Mr./Ms./Mrs. Shaik Nausheen Firdouz with Roll No. 1601-20-736-069,
has successfully completed value added course on Computational Fluid Dynamics for
Automobile and Aviation, organised by DEPT OF MECHANICAL ENGINEERING from

24th July 2023 to 11th Nov 2023.
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